logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
fabriziodb  
#1 Posted : Tuesday, January 21, 2020 11:45:52 AM(UTC)
fabriziodb

Rank: Newbie

Groups: Registered
Joined: 1/21/2020(UTC)
Posts: 0
Italy
Location: rome

hi, i just new on seal report, i want to build my first report.


first question is about "column elements", what is it for? is some aggregation purpose?

i made a sql model, in the sql i retrive the numeric id of a company seat, for the descriptions
i need open a remote xml file. is there a way to create a dummy table (idseat, description) and fill reading from xml.
than i have to add the seat descriptions to the report.

how to i add a combox containg all the seats to select and filter the report?

thanks for help.

epf  
#2 Posted : Tuesday, January 21, 2020 1:02:31 PM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 922
Switzerland

Thanks: 14 times
Was thanked: 154 time(s) in 148 post(s)
For model definition, check https://sealreport.org/Reports#lineModels

to create a model from an XML, you can check and adapt sample 41-No SQL Source RSS.srex

to create a combo for filtering, check https://sealreport.org/Sources#lineEnums

in genral, parse the documentation and the samples to have a clue.

good luck.
fabriziodb  
#3 Posted : Tuesday, January 21, 2020 4:30:35 PM(UTC)
fabriziodb

Rank: Newbie

Groups: Registered
Joined: 1/21/2020(UTC)
Posts: 0
Italy
Location: rome

thanks, i created my first report, it works fine when executed in report designer.

but in development server i get this errore when executed.

can you help me to find what is wrong in dev server?

Sorry, we got an unexpected exception.
Unable to find view template named 'Model'
http://localhost:80/seal/SWExecuteReport
in Seal.Model.RepositoryServer.GetViewTemplate(String name) in Seal.Model.ReportView.get_Template() in Seal.Model.ReportView.<>c.b__197_0(ReportView i) in System.Linq.Enumerable.WhereSelectListIterator`2.MoveNext() in System.Linq.Enumerable.Max[TSource](IEnumerable`1 source) in Seal.Model.ReportView.get_ExternalViewerExtension() in Seal.Model.ReportView.get_AllowPDFConversion() in Seal.Model.Report.get_ForPDFConversion() in Seal.Model.ReportExecution.Render() in Seal.Model.ReportExecution.RenderHTMLDisplayForViewer() in SealWebServer.Controllers.HomeController.SWExecuteReport(String path, Nullable`1 render, String viewGUID, String outputGUID)
epf  
#4 Posted : Wednesday, January 22, 2020 5:00:07 PM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 922
Switzerland

Thanks: 14 times
Was thanked: 154 time(s) in 148 post(s)
it looks like the Web Server has no access to the repository Views sub-folder to find the report templates...
check that the web.config has the correct repository path:

Code:
<applicationSettings>
    <Seal.Properties.Settings>
      <setting name="RepositoryPath" serializeAs="String">
        <value>C:\ProgramData\Seal Report Repository</value>
      </setting>
    </Seal.Properties.Settings>
</applicationSettings>


and that the user running the web server has access to this path...

the DEV server environnement run from Visual Studio:
make sure that you have unblock the zip file downloaded from GitHub to be sure that there is no restrictions...otherwise, check what is wrong with the debugger.

Edited by user Wednesday, January 22, 2020 5:09:05 PM(UTC)  | Reason: Not specified

Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.