Welcome Guest! To enable all features please Login or Register.



Go to last post Go to first unread
#1 Posted : Tuesday, June 11, 2019 1:53:37 PM(UTC)

Rank: Member

Groups: Registered
Joined: 4/7/2019(UTC)
Posts: 23

Thanks: 6 times
We're using the API to render reports inside our own web application. Is working ok but the first time (in a indeterminated period?) a report is executed using the API, takes more than 20 seconds to be executed.
Is there some way to avoid it?

Thanks in advance.
#2 Posted : Wednesday, June 12, 2019 6:07:21 AM(UTC)

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 738

Thanks: 14 times
Was thanked: 136 time(s) in 132 post(s)
The first time the server goes up (same as when you execute your first report with the Report Designer), it creates the repository and compiles all the Templates, plus some additional scripts for the login or report execution, this can take a time.
Once this done, all is in cache and it is fast.
Using IIS Manager, you should configure your Application Pool (Advanced Settings, Idle time out) to keep it live few hours (this depends on the frequency the Server is used), you should also increase the ASP.Net Session of the Web Site (Session State, Time Out).
This is pure IIS and might depend on your use of the Web Server.
thanks 1 user thanked epf for this useful post.
j.torres@tewis.com on 6/12/2019(UTC)
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.