logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
Go to last post Go to first unread
Sharmilee  
#1 Posted : Wednesday, June 20, 2018 12:02:16 PM(UTC)
Sharmilee

Rank: Newbie

Groups: Registered
Joined: 6/20/2018(UTC)
Posts: 0
United States

I have Created Seal Reports and Published it on IIS its working fine.
I want to implement Data Level Authentication based on additional parameter.
following is the code where I passed Additional parameter.

var form1 = $('<form method="post" target="Companyiframe" />');
form1.attr('action', this.sealServer + "/SWExecuteReport");
form1.append($('<input />').attr('name', 'path').attr('value', "\\" + self.ReportName.title + ".srex"));

form.append($('<input />').attr('name', 'path').attr('value', "\\Search - Orders.srex"));
form1.append($('<input />').attr('name', 'format').attr('value', "html"));
form1.append($('<input />').attr('name', 'token').attr('value', token));
form1.children('input').attr('type', 'hidden');
$('body').append(form1);

How can I get "token" in Seal Report Tool, so that I can use it into where clause to restrict data access.

Even I tried another solution as Suggested http://forum.sealreport.....aspx?g=posts&t=746.
Below is my code:


var form1 = $('<form method="post" target="Companyiframe" />');
form1.attr('action', this.sealServer + "/SWExecuteReport");
form1.append($('<input />').attr('name', 'path').attr('value', "\\" + self.ReportName.title + ".srex"));

form.append($('<input />').attr('name', 'path').attr('value', "\\Search - Orders.srex"));
form1.append($('<input />').attr('name', 'format').attr('value', "html"));
form1.append($('<input />').attr('name', 'UserId').attr('value', user));
form1.append($('<input />').attr('name', 'r0_name').attr('value', "CPGUID"));
form1.append($('<input />').attr('name', 'r0_operator').attr('value', "Equal"));
form1.append($('<input />').attr('name', 'r0_value_1').attr('value', "1.2"));
form1.children('input').attr('type', 'hidden');
$('body').append(form1);

as according to this I want to show result which is having CPGUID equals to "1.2",even I tried this using "SWExecuteReportToResult" method also But its not working please suggest solution.

epf  
#2 Posted : Monday, June 25, 2018 3:18:07 PM(UTC)
epf

Rank: Administration

Groups: Administrators
Joined: 12/20/2013(UTC)
Posts: 527
Switzerland

Thanks: 7 times
Was thanked: 72 time(s) in 70 post(s)
Be sure that your target report has a restriction flagged 'Prompted' and named 'CPGUID' to be sure that the value is handled by the engine.
Users browsing this topic
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.